1.1.8-rc2 release (fixes the problem with VLAN interfaces)

A new image is available for testing: http://dev.packages.vyos.net/iso/testing/vyos-1.1.8-rc2-amd64.iso 

If you are using VLAN interfaces, avoid the rc1 one and install the rc2 right away. Thanks to Samir we have identified a bug in VLAN interface configuration scripts (https://phabricator.vyos.net/T435) that prevented them from loading correctly. It was caused by an overlooked syntax error in the new options for ingress/egress VLAN QoS options.

Oddly, the current branch had a correct version of that patch, so 1.2.0 builds are not affected.


7 responses
Just wanted to report that I've been running 1.1.8-rc2 for a week in production with a somewhat complex configuration (multi-WAN, VLANs, comprehensive firewall) without any issues.
Upgraded from 1.1.6 to 1.1.8-rc2 most configurations remained. Lost my OpenVPN configuration. Had to restore from backup to reference configuration and then proceed with upgrade again . Then manually put back OpenVPN configuration.
What happened to the client configuration ? for OpenVPN was it moved ? I can't add a client in 1.1.8-rc2 VyOS 1.1.6 vyatta@vyatta# show interfaces openvpn vtun0 server Possible completions: +> client Client-specific settings + push-route Route to be pushed to all clients subnet Server-mode subnet (from which client IPs are allocated) VyOS 1.1.8-rc2 vyos@vyos# show interfaces openvpn vtun0 server Possible completions: + push-route Route to be pushed to all clients subnet Server-mode subnet (from which client IPs are allocated)
Fixed the bug with OpenVPN config loading. See the forum thread. As of the client options, they are there for me.
3 visitors upvoted this post.